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The developer allows you to create simulations, in-application support, and interactive
documentation in a simulated environment and while working with your data in a live environment.

e Create an outline of the content and record it.
e Record the content as you build your outline.
e Edit steps after you record the content.

e View steps in the various Playback mode.

Setting the Stage

To set the stage, open the environment for which you want to record the content or edit any
delivered content. For our training purposes, you will need to open the PeopleSoft 8.9 Dev
environment. Your stage is now set!

Figure 1
Opening the Developer
1. Launch the UPK Developer from the Start > Programs > User Productivity Kit
menu or by double clicking on the UPK Developer shortcut icon that you can cre- UPK Developer

ated on your desktop (Figure 1).
2. The Developer will open in the Outline Editor view displaying three panes.

3. The first pane, the Outline pane (Figure 2, 1) is located on the left-hand side. The Outline pane
will contain a three level outline structure; modules, lessons and topics.

4. The upper right-hand pane is the Conceptual pane (Figure 2, 2). This pane

. ; i Figure 2
provides conceptual or explanatory information about a module, lesson or
tOpiC. # UPK Developer - PeopleSoft B [= 8%
.- File Edt Vew Insert Tools Topic Help
5. The Introduction AZB b X B0 F 0 IRTEFT AL

pane (Figure 2, 3),
located in the lower
right-hand, provides a
short statement
introducing the topic
selected in the Outline
pane.

The Introductory text
comes from the
Introductory frame
which is the first frame
created in the
Developer and can be
modified.

Introduction
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Understanding the Outline Structure

Insert a New Module

The first level displayed in the Outline pane is the Module. The module is the highest level in the
structure and is represented by a purple book icon. The Module is the folder created within the title

and must contain a unique name. .
Figure 3

¥# UPK Developer - PeopleSoft 8

1. Select an existing module, if Fie Edi View m Taols Topic

applicable.
= | i+ s
2. Click Insert > Module O = 2 | @
(Figure 3, 1). H Lesson..  Chil

3. Type the name for the new module m liopic:. 1]

(Figure 3, 2). @ Enterprize 54 8.9 - Academic Advizement
4. Click the ENTER key on your R BAE PP UPK Developer - PeopleSoft 8
keyboard. @ Enterpl File Edit Wiew lnset Tools Topic Help

a +

Lo

. Enterp . . .
g Enterp "ﬁ 3 = | ,f <3 x ‘ @ @
@ Enterp

ey 0. |

@ Enterpnze 54 8%
{ @ e e
. @ Enterpnize 54 8.3 - Campus Community

- @ Enterprize 54 8.9 - Financial Aid

- @ Enterprise 54 8.9 - Recuiting and Admissions
- @ Enterprize 54 8.9 - Student Financials
@ Enterprize 54 8.3 - Student Records

@ Enterprize 54 8.9 - Bunning Reparts

Advizement

Insert a New Lesson

The second level in the hierarchy is the Lesson. The Lesson is represented by a stack of

papers icon. Every module contains one or more Lessons.
Figure 4

ﬁ UPK Developer - PeopleSoft &

1. Select the desired module or | Fie Edit View | Insert Tools Topic Help
lesson. ‘,_j = 2 | &% Module..  Chl+M

2. Click Insert > Lesson —@ W Chll
(Figure 4, 1).

3. Type the name for the new m
Lesson (Figure 4, 2).

4. Click the ENTER key on your
keyboard.

NEEIE.. i [

] I_IIF;K.DIeveIuper E PeopleSoft 8

File Edit “iew |nzert Toolz Topic Help

Cf 2 | X | d

i+
L4

@ Enterprize 54 8.9 - Academic Advizement
@ Enterprige 54 8.3 - Campus Commurnity
@ Enterprize 54 8.9 - Financial Aid
@ Enterprise 54 8.3 - Recruiting and Admissions
@ Enterprize 54 8.9 - Student Financials
@ Enterprize 54 8.9 -4
@ Enterpnze 54 8.3
E|t|2| Security

@ Roles
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~ Insert a New Topic

You must select a lesson or a topic in the outline to insert a new topic. If a lesson is selected, a new
topic is inserted as the first topic in the lesson. If an existing topic is selected, a new topic is inserted
after the selected topic. You cannot insert a topic if a module is selected; the Topic command on the
Insert menu will be unavailable. The topic name is generally a brief statement describing

the objective of the task covered in the topic.

Each module in a title has its own database. Each topic name is an entry in the
database to which information is linked; therefore, topic names must be unique

within a module for the links to work correctly. # UPK Developer - PeopleSolft 8

Figure 5

1. Select a lesson or topic. File Edit “iew | |ngett Tools Topic Help
2. Click Insert Topic (Figure 5, 1). = e ‘ BGUES S Cilkh ]
3. Type the name for the lesson (Figure 5, 2). U Lesson..  Culd
>

4.  Click the ENTER key on your keyboard. mg -

@ Training Guide

: tﬂ Security

@ Roles
3 UPK Dev;zluper
= File Edit “iew |nsert Toolz Topic Help

2K e X'y

@ Training Guide
E||:|2| Security

E@

@ Enterprize Campuz Solutions 3.9 Fundamer
@ Enterprize Queny for Campus Solutions 8.9
@ Cryztal Reportz for Campuz Solutions 3.9

e ro W) ahi =)

® To Rename an Outline item select the item and choose Edit > Rename.

® To Move an Outline items you can use either drag and drop the item or use the Cut and
Paste commands. When you move an outline item, all its subordinate items move as well.
For example, if you move a lesson, all topics in that lesson move with it.

e |f you Copy a topic to another location within the same module, the original and the copy are
linked together and changes in any occurrence of that topic will be reflected in all other
occurrences of the topic automatically. If you copy a lesson or topic to another module, the
Developer creates a separate copy and places it in the new module. The original and the copy
are not linked across modules.
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e You cannot copy modules since you cannot have two modules with the same name
within a title.

® To Delete an Outline item, select it and choose Edit > Delete. You may decide to delete
an outline item you no longer need. You can delete items whether they have content or
are empty. If you delete items that contain content, the content is deleted as well. When
you delete an outline item, anything below that item in the hierarchy is also deleted.
Therefore, when you delete a lesson, all topics within that lesson are also deleted. When
you attempt to delete an outline item, the Developer prompts you to verify the deletion.
If you delete a topic that is linked to another topic in the module, the Developer displays
a second message, asking you whether you want to delete the other linked topic(s) as
well.

9 You cannot undo a deletion.

Recording the Topic

The Recorder allows you to capture each step of the process with screen captures as you per-
form the task within the application.

To record a Topic

1. To set your stage, navigate to the PeopleSoft Dev Database and login (Figure 6, 1).

Figure 6

>PeopleSoft Links

PeopleTools 8.48 PeopleSoft 8.9 Financials 9 Portal 8.9
DEY Database  — Sandbox Database
Previous DEY Database &DEV'DB-\'
A z
PeopleBooks PeopleBooks PeopleBooks FeopleBooks

DEVELOPER TRAINING MANUAL

The PeopleSoft application will open setting the stage for your UPK recording. Figure 7, 1)

Figure 7

ORACLE’

Fersonalize Content | Lavout

®

[= My Favorites

[+ Self Service

[ Manager Self Service

[> Recruiting

[ Workforce Administration

[> Benefits B
[> Compensation -

[ Stack

[> Tirne and Labar

[ Payroll for Morth America

[+ Global Payrall & Absence Mgmt

[> Payroll Interface

[= Workforce Development
[> Drganizational Development
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2. In the UPK Developer, Click Topic > Record (Figure 8, 1).
Figure 8

F# UPE Developer - PeopleSoft 8

Eile Edit View Inzert Tools | Topic Help
42 40 O i
N
@ Enterprize 54 8.9 - A
; @ Enterprize 54 8.9 - C: Freview Ses|bode
g Enterprize: 5S4 8.9 - Fi v Preview Tyl Mode
- Enterprize 54 8.9 - R )
E i [ F o
@ Enterprize: 54 8.3 - St [EV!EW Lt e
@ Enterprize S8 8.9 - St FeviemEalbiods
@ Enterp.nse SAB3-Ry Eresier Business Erocess Mocumernt
E(@ Security
El.il Rales Eresren | rstrictarn Manusl
. Creating a b Bresiey ohsid H
Eresein Tiesb WErirmemf

9 The Recorder will be displayed on top of the PeopleSoft application (Figure 9, 1).

Figure 9

ORACLE’

Fersonalize Content | Layout

Hecorder - Creating a Mew Hole

Press PrintScreen to begin recording.

®
[> My Favorites
[ Self Service Mext screenshot records:
I Manager Self Senice Last recorded evert:
[> Recruiting
[ Workforce Administration
[ Benefits
[ Compensation
[- Stock
[> Time and Labor
[> Payroll for Morth America
[> Glohal Payroll & Ahsence Mgmt
[> Payrall Interface
[ Workfarce Development
[ Organizational Development

Start Screen

The Recorder allows you to take pictures of each step you perform in a task with a screen capture.
This is completed by taking a series of pictures of the way the screen looks after each step in a task.

3. To Record a Topic, press the PRINTSCREEN key on you keyboard to capture a screen
shot for every step in the procedure.

Figure 10

The status indicator light on the recorder 7 Recorder - Creating a New Role
must be GREEN to begin recording Presz PrintScreen to begin recording.

(F i gure 10 1) Mext screenshot records:  Start Screen
y ? Last recorded event:

— cc\

/
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Each screen image you capture contains an action, such as a mouse click or keyboard stroke. The
combination screen capture and action is called a Frame (Figure 11).

4. If an action is used on the screen, TWO PRINTSCREENSs will be needed. The first to capture
the screen; the second to capture the action.

Quick Step Guide to Recording a Topic

1. Click on the Topic for which you want to the record.

2. Click Topic > Record.

Press PRINTSCREEN to record the first frame from your PeopleSoft stage.
Perform the first step in your procedure.

Press PRINTSCREEN.

o a0 k& w

Perform the next step in your procedure > Press PRINTSCREEN.
7. Repeat steps 4 through 5 as needed to complete all the steps for your procedure.
8. Click Finish after you have recorded your last step.

9. Click Exit to Close

You can open the Topic Editor at any time to modify the frames, settings or bubble text for the
frames. (Figure 11, 1)

1. Select the Topic you want to edit from the UPK Developer Outline.

. . . Figure 11
2. Click Edit Topic. o -
eveloper - Peoplebolt 8 |Lieating a New Hole) P R
File Edit Wiew Goto Jnset Delste Took Help
AlxrFee a=al . Ha e
Jumpin point Frame ID: | T s | 2B R A ‘ Display: | Player - See It/ Tra It - |
ployee g reg onte 0s0 eine plorer provided b ows0 e | Bubble Properties
a hitp:/7psB9web. towson.edur 8081 /psp/SABIDEY /EMPLOYEE /HAMS /h/ ?tab=DEFALILT KL L B | & “‘F’l % &
= =B 7 U|p
The Topic Editor
window will open and ORACLE’ R 8B g
) ) 80 8 |2E]
dISp|ay the SCI’eenShOt Personalize Content | Layout e &|7 BB B
file for the current — Acon Properies z
T Al key) = | Gontiol key | | St key)
fram €. Application:
ot bype: =
t name:
nal name:
Creating a New Role elay time (5] [5.0 =
nlaEa g
Press [Erter] to start.
af?
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The Frame Structure window contains a circle for every frame of the
topic as follows: (Figure 12, 1).

Adding Text to the Bubble

FRAME TYPE

Introduction Frame

Frame

End Frame

Figure 12

Fie Edk Yew Goto wet [elote Toch Hep

1. Navigate to the desired

Alx(wee awal PR

v g [ Feaen [0 e

frame by clicking on the
Frame Icon (Figure 12, 1).

2. In the Text Edit Pane begin
typing any necessary text
(Figure 12, 2).

3. The newly entered text will
be displayed in the bubble on
the Frame (Figure 12, 3).

Ak iy sy bt o than Bk,

heee in the Text Ede Pane.

Creating a New Role

- Sem it/ Teplt =]
=] BubbkPeete: ——
(A
EEIAEB ;U g

Rty ey tedd bothe =
Butile here i the Tret Bt Pae.

S i
CEr R B

— duchion Frogartes

[l e L

P [Erte] b bt

I

9 The Introduction Frame displays a green dot only because it is the selected frame (Figure 12, 1).

Editing Text in the Bubble

1. To edit existing text in the Bubble (Figure 12A, 1), click the Insert template text as user

2.

text icon (Figure 12A, 1).

Enter new text in the Text Edit Pane (Figure 12A, 2).

Figure 12A

Frame |D: E8

T@ (& o & [29] 9 [74 =5 =) | Displar [Pin-Seet/ Tk |

@lo-am-Dl 2R
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Enter the desired
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Owner: *Query field, Enter
Query Definition: VINY_NUM",

= Bubble Properties ————

o ah e AR

=E=E=|B 7 U|p

nter the desired =
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*Query field. Enter
PINY_NUM",

|

o A
 Action Propetties ———————— x
[String input |

= | &ltkey T | Cortral ke [T Shittkey.

Application:  PeopleSaft §
Object type: | Editfield ~

Object name:  [“Quemy

EAEIENE

!|1
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Repositioning Text in the Bubble

1. To reposition added text in the Bubble (Figure 12B, 1), Click the Show custom text first

icon (Figure 12B, 2).

Figure 12B, 1

Olld 4 M |- e

[ FrameiD: E8

| @ |jo' & ono'l"""ﬂl ) ”ﬁﬁ A | Display. Frint - See It/ Try It &2 |
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i
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S o —
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[ X

Testing

Enter the desired
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| -]

28295y
EsEEaaa
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Object type: Editfield 'I
Object name:  [*Cuery

Figure 12B, 2

El

2. Click the Show custom text first icon a second time to reposition the text to the bottom of

the Bubble (Figure 12C, 1).

Figure 12C
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Repositioning the Bubble Pointer

1. To reposition the Bubble Pointer (Figure 12D, 1), Click the Pointer Position Icon
(Figure 12D, 2)

2. Click the position of the Bubble Pointer. (Figure 12D, 2)
3. Your Bubble Position Pointer has now be repositioned. (Figure 12E, 1)
Figure 12D

- Q.|.,.-+
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Once you have recorded your Topic, you can now preview your Topic in several modes by
clicking on the drop down arrow in the Preview Mode Field and selecting the desired Mode:

(Figure 13, 1)

1. See It Mode - No interaction is required from the user to preview

the recorded task. Press the enter key to view N

at your pace or allow the demonstration to play

) Figure 13

without any user interaction. To exit the See It [F 43 | Preview Try I Mode

R))

Mode, press the ESC key or click on the X. Preview Ses t Mods

. Prewvies Try I Mod
2. Try It Mode - Allows the user to preview the !' revfew e
i i Previewy Know it Moce
topic using the Enter key to advance to the next
step. To exit the Try It Mode, press the ESC

Previewy Do it Mode - Manual Advance

f—

key or click on the X. Preview Business Process Document

. Do 1t Mod i | back de i di Previewy Instructor Manual
. (o] ode - Is playback mode Is opened In Preview Job Ajd

the target application (PeopleSoft) allowing the_ Preview Test Document
user to complete the task, step by step. To exit Preview Training Guide

the Try It Mode, press the ESC key or click on

the X. e ——

4. Know It Mode - Is an assessment-type playback mode in which users are instructed to
complete a particular task. Users do not receive step-by-step instructions for completing
a task. Instead, they complete the steps on their own in a simulated environment, and

they are scored on how accurately they complete them.

Before inserting a frame, you will I )

”””””””””””””””””””””””””””””””””””””””””””””” Figure 14

need to set your stage to match [ £t sex ot joss fos tisp -
the correct step in the task EIENEIE] - |s nal e

. s E = Alternative Action Er o B ||
where you want to insert the b 2 55 et el A
2 s ioso AR ..,

|I§ = 7 ‘ Display: | Player - Ses It £

frame. You insert a new frame O e e [

AINTAIN_SECURITY. ROLEMAINT GBL?PORTAL ¥ ] |§| \Z\ F

after the current frame. S el

o¥a Explanation Frame

Links @ Home -Busst | ok Frame 2 PS_Upgiad ancisls @ SharePaint- 0TS @ | Bulletin Loyola 2 | Customize Li

DAY gg|v| & Fioles

W Cleared Duke Lacrosse Playe.. | 3 Home - Bursar

1. Set the PeopleSoft stage to
the correct position to begin ORACLE
recording the task.

= Permissions & Roles [«
- Permission Lists
— Copy Permission Lists

2. Switch back to the Developer - Delele Parrission

Roles

Find an Existing Value

Lists Enter any infarmation you have and click Search. Leave fields blank for a list of all values

|G-8 - -

- Delete Roles

3. Double click on the Topic. e |
H 5 H [» Password Conflguration earch by ole Name > hedins wi
The'Topl_c will open in the Doy L Cace Somitvn
TOpIC Edltor' [> Query Security Click the Add a New
[» Encryption Search Advanced Search Value tab.

— Common Queries

— Mass Change Uperator
Wass Channs Operatar Find an Existing Walue IAuu a Mew Value

4. Using the Frame Icons, |
select the frame after which o
you want to insert a frame. b Bearch Engine

[ Personalization
(Figure 14 1) > Process Gcheduler

[ Cube Manager

10
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5. Click Insert > Missing Frame (Figure 14, 2).

6. The Recorder will open allowing you to record the needed screenshot.
7. Press PRINTSCREEN to record the screen shot.

8. Perform the necessary action and Press PRINTSCREEN.

9. Repeat steps 7 and 8 as needed.

10. Click Finish to exit the recording session

Jump-in point:
£

Fie Edt View Goto Inset| Delete Took Help

B oo
| E3Fah

Wecisian frame
Derision Path

Links g | Home-Bursar @ | OnlineInvoice PRD | PS 2 PS_Upgrade ¢ | PS_Financials & Sh

UPK Developer - PeopleSolt 8 [Creating a New Role)

2 | Bulletin_Loyola 2 | Customi

X | W Cleared Duke Laciosse Playe... | @ Home - Bursar J i - B - o

1. Navigate to the frame you want it = MFeror (s
to delete using the Frame Icons ~ fET e e
(Figure 15, 1).

P gg|-|gﬂu|es

2. C|I'Ck Delete > Frame ORACLE

(Figure 15, 2).
< Permissions &Roles (4]
3. Click Yes. ~ Comnpamiszion Lists

— Delete Permission

— Ruoles
— Copy Roles
— Delete Roles
— Execute Role Rules
- Password Configuration
[» Directary
[ Security Objects
[ Query Security
[ Encryption
— Commaon Queries
— Mass Chance Operator
Security
[ Ltilities
[ Wiorkflow:
[ Portal
[» Search Engine
[ Personalization
[» Pracess Scheduler

[+

Roles
Enter any infarmation you have and click Search. Leave fields blank for a list of all values.

Find an Existing Value

Search by: |Ra|e Namej hegins wi

I~ case Sensitive

Search | Advanced Search

Find an Existing Value \ Add a MNew Value

Click the Add a Hew
Value tah

Figure 15
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